Глава 10. Отчёты о проводках

Как говорилось выше (см. п. П1.2. Проводки), элементарной единицей учётной информации в ФинГраде является проводка — запись о перемещении средств между двумя счетами управленческого учёта. Каждая хозяйственная операция в организации записывается в ФинГраде в виде одной или нескольких проводок.

В главе Глава 7. Ввод проводок мы описали окно Ввод проводок, с помощью которого в ФинГраде можно вводить новые проводки, и возможности пользователя по редактированию проводок. А в этой главе мы расскажем о том, какие отчёты о проводках имеются в ФинГраде, и как их использовать. Будут описаны:

  1. Отчёт об операциях по счёту или группе счетов (выписка) — п. 10.3. Примеры использования выписки по счёту или группе счетов.
  2. Отчёт о поиске проводок — п. 10.4. Поиск проводок.
  3. Возможности пользователя при просмотре отчётов — п. 10.2. Возможности при просмотре отчёта.
  4. Использование сохранённых отчётов — п. 10.7. Использование сохранённых отчётов.

10.1. Выписка по счёту

Это отчёт об операциях по счёту или группе счетов (иными словами, выписка по счёту) за определённый период времени. В таком отчёте можно не только выбрать период времени, по которому производится отчёт, но и:

  • формировать отчёт по группе счетов с детализацией по счетам;
  • формировать отчёт по проводкам с заданными значениями аналитик;
  • группировать проводки по значениям аналитики, выводить суммарные результаты по группам;
  • формировать отчёт о проводках с заданными корреспонденциями счетов.

10.1.1. Диалоговое окно отчёта

Чтобы вывести выписку по счёту или группе счетов:

  • выберите в меню ФинГрада пункт Отчеты, а в нём — пункт Выписка по счёту;
  • или выберите в главном меню ФинГрада пункт Работа, а в нём — пункт Выписка по счёту;
  • или щёлкните кнопку на панели инструментов ФинГрада.

Откроется окно с запросом параметров отчёта:

10.1.2. Задание параметров выписки по счёту

Диалоговое окно Выписка по счету содержит разные настройки. Мы объясним их по порядку, а потом приведём примеры. Вы убедитесь, что пользоваться этим окном просто. При желании вы можете сначала изучить примеры:

Итак, о настойках диалогового окна Выписка по счёту:

  1. В поле Шеф счета выберите счёт или группу счетов для отчёта. Для этого кликните в поле Добавить счёт...  Откроется окно Выбор счёта:

Счёт или группу счетов можно выбрать двойным щелчком по их названию. Чтобы быстро найти нужную строку, начните вбивать её название. ФинГрад покажет строки, в которых есть вводимые символы:

Используя кнопки и , переключайтесь между найденными вариантами и выберите нужный.

Поиск работает и в режиме отображения Список, и в режиме Дерево.

Замечание.Плюс древовидного отображения в том, что видно всю структуру и принадлежность счетов группам. Плюс отображения списком — все элементы расположены в алфавитном порядке. В результатах поиска режима Список удобнее ориентироваться — вы видите только подходящие варианты, без вложенности и структуры:

После выбора счёта или группы счетов подтвердите действие, нажав кнопку .

  1. Включите свойство Группировать по счетам, если нужно группировать данные отчёта по выбранным счетам:

  1. Когда счета или группы счетов выбраны, в выпадающем списке ниже определите режим учёта сальдо:

Эти режимы работают так:

Параметр

 

Если выбрать, то ФинГрад…

Без входящего сальдо

 

не учитывает в отчёте входящее сальдо по счёту.

Сальдо по курсу на начало периода

 

преобразует данные о суммах в валюте, отличающейся от основной валюты, по курсу на начало периода отчёта.

Сальдо по историческому курсу

 

преобразует данные о суммах в валюте, отличающейся от основной валюты, по курсу на дату хозяйственной операции.

 

  1. Выберите шаблон вывода в выпадающем списке справа:

В списке находятся все доступные шаблоны документов. Подробнее о шаблонах см. Глава 10. Отчёты о проводках.

  1. Задайте период, за который составляется отчёт.

Задание периода отчёта с помощью поля Период. Наиболее удобный и пригодный в большинстве случаев способ задания периода отчёта — с помощью поля Период. Если щёлкнуть мышью в поле под надписью Период, ФинГрад выведет панель меню:

В этой панели вы можете:

  • щёлкнув одну из надписей в правой колонке меню (Все, Сегодня, Вчера, Вчера и сегодня, За последние 3 дня и т. д.), выбрать соответствующий период отчёта;
  • щёлкнув номер года, название месяца или квартала, выбрать этот год, месяц или квартал в качестве периода отчёта;
  • выбрать в качестве периода отчёта несколько месяцев, кварталов или лет. Для этого щёлкните мышью наименование начального месяца, квартала или года. Затем, не отпуская кнопку мыши, переместите указатель мыши к наименованию конечного месяца, квартала или года, после чего отпустите кнопку мыши:

  • щёлкнув мышью надпись — вывести в панель меню предыдущие года;
  • щёлкнув мышью надпись — вывести в панель меню следующие года.

Задание периода отчёта с помощью календаря. Альтернативный метод задания периода отчёта — с помощью календаря. Вы можете задать произвольный период отчёта, в том числе такой, который невозможно выбрать с помощью поля Период.

Если щёлкнуть мышью по треугольнику под надписью Начальная дата или Конечная дата, то ФинГрад выведет календарь, в котором вы можете выбрать нужную дату.

В этом календарике вы можете:

  • щёлкнув мышью надпись Сегодня, установить в качестве периода сегодняшнюю дату;
  • щёлкнув мышью дату, установить эту дату в качестве границы периода;
  • щёлкая мышью по символам и в верхней части календаря, вывести в него нужный месяц;
  • щёлкнув мышью по номеру года, выбрать для календаря нужный год, потом месяц в году, потом число в месяце.
  1. При необходимости справа вы можете выбрать Корреспондирующие счета:

Принцип поиска и выбора тот же, что и для Шеф счетов. За выбранный период времени в отчёт может попадать большое количество проводок по разным счетам. Добавлением корреспондирующего счёта вы фильтруете проводки, выбирая нужную информацию. Например, отображая в отчёте только платежи за аренду, переводы заработной платы, закупку или продажу товара.

  1. В блоке Аналитики выписки вы можете кликнуть в поле Добавить аналитику...

и выбрать одну или несколько аналитик.

Этот блок применяется для двух целей:

  1. для группировки в отчёте проводок по значениям аналитик. Добавьте аналитику и включите режим Группировать:

ФинГрад сгруппирует в отчёте проводки по значениям аналитик, указанных в списке Аналитики выписки;

  1. чтобы выводить в отчёте проводки только с указанными значениями заданных аналитик (эти значения выбираются в столбце Ограничения). Кликните по ссылке Без ограничений. Откроется справочник аналитики:

Установите флажки слева от нужных значений аналитики: — включить данное значение аналитики в отчёт, — не включать. Закончив выбор, щёлкните мышью кнопку . Вы вернётесь в окно с запросом параметров отчёта. В столбце Ограничения будут перечислены выбранные значения аналитик.

  1. ФинГрад позволяет суммировать в отчёте проводки с одинаковой корреспонденцией счетов и одинаковыми значениями выбранной аналитики. Это может быть полезно, например, чтобы вывести не просто список проводок по начислению заработной платы, а отчёт о том, сколько за выбранный период времени начислено заработной платы каждому сотруднику организации.

Чтобы в отчёте выполнялось суммирование по значению аналитики, выполните следующие действия:

  1. раскройте блок Дополнительно в нижней части окна Выписка по счету:

  1. раскройте выпадающий список в строке Суммировать по аналитике и выберите аналитику. Чтобы найти нужную строку быстрее, начните вводить название аналитики. ФинГрад подсветит подходящее значение.

После выбора аналитики появится свойство Раскрывать на том же листе:

  1. установите нужное значение режима Раскрыть на том же листе. Если этот режим включён, то ФинГрад разделит окно отчёта на две части. В верхней части он выведет отчёт, а в нижней части — детализацию (расшифровку) текущей суммы в отчёте. Часто это очень удобно.
  2. При необходимости задайте нужное значение параметра Шаблон детализации. Этот параметр позволяет указать шаблон документов, по которому будет отображаться расшифровка текущей суммы.

Замечание.1. Режим Суммировать по аналитике не совместим с режимом Группировать по аналитикам. 2. В блоке Дополнительно вы можете включить режим Показывать сторн. В этом случае в отчёт будут попадать сторнированные проводки. Сторнированные проводки отображаются в отчёте красным цветом.

  1. После того, как вы настроили параметры отчёта, нажмите кнопку в окне Выписка по счету. ФинГрад выведет на экран отчёт с заданными параметрами:

Если вы передумали составлять отчёт, нажмите кнопку .

 

Другие действия после задания параметров отчёта. Нижняя часть окна Выписка по счету содержит ещё несколько кнопок:

Они позволяют выполнить следующие действия:

Кнопка

 

Действие при нажатии

 

сохраняет параметры отчёта для повторного использования. Для сохранения введите название и выберите группу:

 

сбрасывает все настройки окна.

 

выводит отчёт с заданными параметрами на принтер.

 

формирует отчёт с заданными параметрами и сразу же экспортирует его в Excel.

10.2. Возможности при просмотре отчёта

Расскажем о том, какие возможности имеются при просмотре отчёта, и что следует делать, когда отчёт больше уже не нужен. Эти возможности примерно одинаковые у всех отчётов, поэтому мы выделили их описание в отдельный параграф.

10.2.1. Перемещение по просматриваемому отчёту

Как правило, отчёты в ФинГраде достаточно объёмные, и на одном экране целиком не помещаются. Для перемещения по отчёту по горизонтали и вертикали вы можете использовать стандартные средства Windows.

Перемещение по отчёту по вертикали (вверх-вниз) осуществляется так:

  • можно перелистывать отчёт по вертикали, нажимая на клавиатуре клавиши и ;
  • можно перемещаться по отчёту на строку вверх и вниз с помощью клавиш перемещения курсора и ;
  • можно перетаскивать мышью «бегунок» на вертикальной линейке прокрутки;
  • если мышь оборудована колёсиком, то можно установить указатель мыши в окно отчёта и перемещаться по отчёту вверх-вниз, прокручивая колёсико мыши.

Перемещение по отчёту по горизонтали (вправо-влево) осуществляется так:

  • можно перемещаться по отчёту на ячейку вправо и влево с помощью клавиш перемещения курсора и ;
  • можно перетаскивать мышью «бегунок» на горизонтальной линейке прокрутки.

Опытные пользователи используют для перемещения по отчётам и другие клавиши и комбинации клавиш. Мы приведём их перечень в следующей таблице:

Клавиши

 

Назначение

,

 

Перемещение на ячейку налево, направо

,

 

Перемещение на ячейку вверх, вниз

 

Пролистывание документа вверх

 

Пролистывание документа вниз

 

Переход к самой левой ячейке в текущей строке

 

Переход к ячейке, находящейся в текущей строке и самой правой используемой в текущем документе колонке

+

 

Переход к самой левой ячейке в первой после заголовков строке отчёта

+

 

Переход к ячейке, находящейся в текущей строке и самой правой используемой в текущем документе колонке

+,
+

 

Перемещение влево и вправо к границе диапазона заполненных ячеек в строке или следующему заполненному диапазону ячеек в строке. Здесь заполненный диапазон ячеек — это набор последовательных непустых ячеек в строке, ограниченный слева и справа пустыми ячейками или началом строки.

+,
+

 

Перемещение вверх и вниз к границе диапазона заполненных ячеек в колонке или следующему заполненному диапазону ячеек в колонке. Здесь заполненный диапазон ячеек — это набор последовательных непустых ячеек в колонке, ограниченный сверху и снизу пустыми ячейками или заголовками.

10.2.2. Печать отчёта

Просматриваемый отчёт Вы можете:

  • напечатать целиком— для этого надо щёлкнуть кнопку на панели инструментов, или нажать комбинацию клавиш + (буква P — латинская);
  • вывести на экран в том виде, в котором отчёт будет напечатан — для этого надо щёлкнуть кнопку на панели инструментов, или выбрать команду меню Работа | Предварительный просмотр:

С помощью кнопок на панели инструментов Вы можете изменить параметры страницы, масштаб при выводе на печать, и напечатать отчёт (кнопка Печать).

  • можно напечатать выделенный фрагмент отчёта — для этого надо выделить этот фрагмент и нажать комбинацию клавиш + (буква K — латинская).

10.2.3. Экспорт в Excel

Вы можете экспортировать просматриваемый отчёт в табличный редактор Excel:

  • для экспорта отчёта на лист, открытый в табличном редакторе Excel, надо щёлкнуть кнопку на панели инструментов, или выбрать команду меню Работа | Экспорт в Excel | На лист;
  • для экспорта отчёта в файл табличного редактора Excel надо выбрать команду меню Работа | Экспорт в Excel | В файл.

При экспорте в файл Excel можно указать имя макроса, который должен запускаться для созданного Excel-файла.

10.2.4. Изменение параметров отчёта

Если при просмотре отчёта щёлкнуть кнопку на панели инструментов отчёта, ФинГрад выведет на экран окно параметров отчёта. Вы можете изменить эти параметры, и щёлкнуть мышью кнопку . ФинГрад отобразит в отчёте сведения в соответствии с заданными Вами параметрами.

10.2.5. Изменение масштаба просмотра

Чтобы изменить масштаб вывода отчёта, при просмотре отчёта надо щёлкнуть треугольничек в кнопке на панели инструментов отчёта, и выбрать масштаб в выведенной панели меню:

10.2.6. Автофильтр при просмотре отчёта

ФинГрад может показывать в отчёте только строки с указанными Вами значениями. Эта возможность называется режимом автофильтра.

Установка автофильтра. Если при просмотре отчёта щёлкнуть мышью кнопку (Автофильтр) на панели инструментов отчёта, то ФинГрад включит режим автофильтра. Кнопка на панели инструментов отчёта в этом режиме будет показываться выделенной («нажатой»). А в строке с описаниями назначения колонок отчёта появятся кнопки с направленными вниз треугольничками :

Если щёлкнуть мышью одну из этих кнопок-треугольничков, то на экран выводится панель меню с перечнем значений в колонке отчёта:

В этой панели меню, щёлкая мышью квадратики в начале строк, надо отметить галочками те значения, которые Вы хотите видеть в этой колонке в строках отчёта. Щелчок мышью по квадратику слева от надписи (Showall) позволяет установить или убрать галочки у всех строк в перечне (в панели меню).

Например, на рисунке выше задан режим показа строк отчёта с датами 28.11.2011 и 29.11.2011.

Установив все нужные галочки, надо щёлкнуть мышью кнопку . И ФинГрад будет показывать в отчёте только те строки, у которых в данной колонке имеются значения, которые Вы выбрали.

Фильтр по нескольким колонкам. При желании Вы можете установить фильтр по нескольким колонкам отчёта. В этом случае ФинГрад показывает только те строки отчёта, которые удовлетворяют всем установленным фильтрам.

Отмена автофильтра. Чтобы отменить режим автофильтра, щёлкните мышью кнопку (Автофильтр) на панели инструментов отчёта.

10.2.7. Поиск и замена строк символов

ФинГрад позволяет искать в отчёте строки символов, а также заменять одни строки символов на другие.

Поиск строки символов. Чтобы найти строку символов, щёлкните кнопку на панели инструментов отчёта, или нажмите комбинацию клавиш +. ФинГрад выведет запрос параметров поиска:

Введите в поле справа от надписи Найти искомую строку символов, и щёлкните мышью кнопку . ФинГрад выделит первую ячейку, содержащую заданную Вами строку символов. Вы можете найти следующую такую ячейку, снова щёлкнув мышью кнопку .

Если ячейки, содержащей искомую строку символов, не было найдено, ФинГрад сообщит об этом:

Для закрытия запроса параметров поиска щёлкните в нём мышью кнопку или нажмите клавишу .

Режимы поиска. Вы можете установить следующие режимы поиска:

Режим

 

Если режим включён, то ФинГрад…

Учитывать регистр

 

Учитывает регистр букв (разницу между прописными и строчными буквами) при поиске.

Ячейка целиком

 

Будет искать лишь те ячейки, у которых значение ячейки в точности равно введённой строке символов.

Область поиска. ФинГрад ищет искомую строку символов, начиная с текущей ячейки и до конца листа. Но если Вы перед началом поиска выделили в отчёте диапазон ячеек, то поиск будет происходить только в пределах выделенного диапазона ячеек.

Замена строк символов. Чтобы заменить в отчёте строку символов на другую строку символов, можно:

  • нажать комбинацию клавиш +;
  • или щёлкнуть мышью кнопку на панели инструментов отчёта, а в выведенном запросе параметров поиска щёлкнуть ярлычок вкладки .

ФинГрад выведет запрос параметров замены:

Введите в поле справа от надписи Найти искомую строку символов, а в поле справа от надписи Заменить на — заменяющую строку символов. При желании можно установить нужные значения режимов Учитывать регистр и Ячейка целиком (см. выше). После этого Вы можете использовать следующие кнопки запроса параметров замены:

Кнопка

 

Выполняет следующее действие

 

Найти и выделить первую ячейку, в которой содержится искомая строка символов

 

Найти первую ячейку, в которой содержится искомая строка символов, и заменить в ней искомую строку символов на заменяющую строку символов.

 

Заменить искомую строку символов на заменяющую строку символов во всех ячейках, начиная с текущей ячейки и до конца отчёта, или во всех выделенных ячейках (если на листе выделен диапазон ячеек).

 

Закрыть запрос параметров замены.

10.2.8. Сортировка строк отчёта

С помощью кнопок и на панели инструментов отчёта Вы можете упорядочить строки отчёта по значению текущей колонки:

  • щелчок мышью по кнопке упорядочит строки отчёта по возрастанию значений в текущей колонке отчёта;
  • щелчок мышью по кнопке упорядочит строки отчёта по убыванию значений в текущей колонке отчёта.

10.2.9. Настройка ширины колонок отчёта

Изменение ширины колонки отчёта. Чтобы изменить ширину колонки отчёта, укажите мышью на правый край заголовка колонки. Указатель мыши примет такую форму:

Теперь Вы можете изменить ширину колонки, перетаскивая указатель мыши. То есть, для изменения ширины колонки надо нажать левую кнопку мыши (когда указатель мыши имеет форму ) и, не отпуская её, переместить границу колонки в нужное положение, передвигая мышь влево или вправо. После чего следует отпустить левую кнопку мыши.

Возврат стандартных ширин колонок отчёта. Вернуть стандартную ширину колонок в отчёте можно, выбрав команду меню Настройки | Вернуть стандартную ширину колонок.

10.2.10. Настройка видимости колонок отчёта

В проводках ФинГрада может содержаться множество самых разных сведений, в том числе и чисто служебного характера. Каждому виду сведений в проводках соответствует своя колонка ФинГрада. Чтобы не утомлять пользователей излишними сведениями, ФинГрад выводит в отчётах только те колонки, в которых содержатся наиболее необходимые сведения. Остальные колонки на экране не показываются.

Запрос «Настройка колонок». Если Вы хотите при просмотре отчёта вывести какие-либо дополнительные колонки, или скрыть излишние колонки, следует:

  • нажать клавишу ;
  • или щёлкнуть мышью кнопку (Настройка видимости колонок) на панели инструментов.

ФинГрад выведет на экран запрос Настройка колонок:

В этом запросе надо щелчками мыши отметить галочками показываемые колонки, или убрать пометки (галочки) слева от названий ненужных колонок. ФинГрад сразу же осуществит эти изменения в видимости колонок. Закончив настройку показа колонок, надо щёлкнуть кнопку запроса .

Замечание. Чтобы убрать ненужную колонку отчёта, можно изменить мышью ширину колонки до нуля. А восстановить «спрятанную» колонку можно, указав мышью в строке заголовков колонок чуть правее той линии, в которую свернулась «спрятанная» колонка. Указатель мыши примет такую форму: . Нажмите левую кнопку мыши, переместите указатель мыши вправо и отпустите левую кнопку мыши.

Режимы показа служебных колонок. Режимы показа служебных колонок ФинГрада задаются с помощью меню ФинГрада, пункт меню Настройки:

Режим

 

Если режим включён, то ФинГрад…

Показывать номер проводки

 

Показывает колонку с названием ID, содержащую номер проводки в базе данных. У проводок, еще не нанесённых в базу данных, значение в этой колонке пустое.

Показывать пользователя и дату ввода

 

Показывает колонки Пользователь и Дата ввода. В них отображается идентификатор пользователя, занёсшего проводку в базу данных, и дата внесения проводки в базу данных.

Показывать автора и дату создания

 

Показывает колонки Автор и Дата создания. Для проводок, импортированных из программ 1C, баз данных SQL и других сторонних источников, в этих колонках отображается идентификатор пользователя и дата исходной проводки. Для новых проводок, созданных в самом ФинГраде, в эти колонках содержится идентификатор пользователя и дата проводки. И при изменении проводки эти сведения сохраняются (в отличие от колонок Пользователь и Дата ввода).

Показывать сторн

 

Показывает колонку Сторн. Для обычных проводок значение в этой колонке — ноль. Для удалённых проводок там хранится номер сторнировочной проводки, а для сторнировочных проводок — номер соответствующей удалённой проводки.

Показывать статус строки

 

Показывает колонку Статус, в которой отображается служебная информация о статусе проводки.

Показывать параметры зависимых

 

Показывает колонки Генерировать зависимые,Имя правила, ID правила, и ID правила зависимой проводки, в которых отображается служебная информация о генерации зависимых проводок.

10.2.11. Переход в другое окно

Закончив просмотр отчёта, Вы можете перейти к просмотру другого отчёта, щёлкнув мышью пункт меню Окна, и затем щёлкнув мышью пункт с названием нужного окна в выведенной панели меню:

Кроме того, перейти в другое окно можно, щёлкая кнопки и на панели инструментов ФинГрада, или нажав комбинацию клавиш +.

При переходе в другое окно на экран может быть выведена другая информация, но исходное окно отчёта при этом не будет закрыто. При желании Вы сможете в любой момент снова вывести этот отчёт на экран, щёлкнув мышью пункт меню Окно, и затем выбрав в выведенной панели меню название нужного отчёта (например, отчёт по счёту Касса будет называться так: Касса – Выписка по счёту).

10.2.12. Закрытие отчёта

Если просматриваемый отчёт больше не нужен, Вы можете закрыть окно отчёта:

  • нажав комбинацию клавиш +;
  • или щёлкнув мышью кнопку в правой части строки меню (а если отчёт выведен в отдельном окне документа — то кнопку в правом верхнем углу этого окна).

10.2.13. Сохранение параметров отчёта

ФинГрад позволяет создавать отчёты с довольно сложными настройками. Задание всех необходимых настроек для такого отчёта может потребовать немало времени. Поэтому ФинГрад позволяет сохранять настройки отчётов, и формировать отчёты со сделанными настройками.

Чтобы запомнить параметры просматриваемого отчёта, надо щёлкнуть мышью кнопку на панели инструментов. ФинГрад выведет запрос, в котором предложит задать имя для сохраняемых параметров отчёта:

Введите в поле Имя отчёта имя, содержательно описывающее формируемый при данных параметрах отчёт. Введите в поле Группа отчетов наименование группы, в которую будет помещён отчёт, или выберите там наименование этой группы из списка, щёлкнув значок в правой части этого поля. После чего щёлкните мышью кнопку .

О том, как использовать сохранённые отчёты, рассказано в п. 10.7. Использование сохранённых отчётов.

Замечание. Кнопка может выводиться и в окне с запросом параметров отчёта. Щёлкнув её мышью, Вы точно так же можете сохранить параметры отчёта.

10.3. Примеры использования выписки по счёту или группе счетов

Разберём несколько случаем использования выписки по счёту.

10.3.1. Пример 1 — выписка по группе счетов

Сформируем выписку по группе счетов Операционные расходы с детализацией по счетам. Для этого:

  1. Выведем окно с запросом параметров отчёта — выберите в главном меню ФинГрада пункт Отчеты, а в нём — пункт Выписка по счёту. Или щёлкните кнопку на панели инструментов ФинГрада.
  2. Щёлкнем мышью в поле Добавить счет... и выберем группу счетов Операционные расходы (чтобы быстрее найти это название в списке, можно ввести с клавиатуры первые символы названия: Опе...).
  3. Зададим период отчёта, указав начальную и конечную дату или выбрав период.
  4. Включим режим Группировать по счетам — щелчком мыши поставим галочку слева от названия этого режима.

  1. Щёлкнем мышью кнопку в окне с запросом параметров отчёта.

ФинГрад выведет отчёт (выписку по счёту) на экран:

Как видно,сформированная выписка разделена на секции, соответствующие счетам из выбранной группы счетов Операционные расходы. В выписку будут включены только те счета из этой группы, по которым имеется движение средств за указанный период, или же сальдо на начало периода не нулевое.

10.3.2. Пример 2 — группировка проводок по значениям аналитики

Сформируем выписку о выдаче денег под отчёт с группировкой по сотрудникам, которым выдавались деньги под отчёт. Для этого:

  1. Выведем окно с запросом параметров отчёта — выберите в главном меню ФинГрада пункт Отчеты, а в нём — пункт Выписка по счёту. Или щёлкните кнопку на панели инструментов ФинГрада.
  2. Щёлкнем мышью в поле Добавить счет... и выберем счёт Деньги под отчёт (чтобы быстрее найти это название в списке, можно ввести с клавиатуры первые символы названия: День...).
  3. Зададим период отчёта, указав начальную и конечную дату или выбрав период.
  4. В блоке Аналитики выписки щёлкнем в поле Добавить аналитику...
  5. В списке аналитик выберем аналитику Сотрудник.
  6. В столбце Группировать включаем группировку, нажав галочку .

  1. Щёлкнем мышью кнопку . ФинГрад выведет отчёт (выписку) на экран:

Как видно, в созданном отчёте все проводки разделены на группы. Каждая группа соответствует значению аналитики Сотрудник. В отчёт включаются только те значения аналитики Сотрудник, для которых имеется движение средств по выбранному счёту за указанный период, или же сальдо на начало периода не нулевое.

10.3.3. Пример 3 — суммирование проводок по значениям аналитики

Предположим, что в отчёте о выдаче денег под отчёт с группировкой по сотрудникам нам нужны лишь итоговые данные — сколько денег за период выдавалось под отчёт конкретному сотруднику, сколько им возвращено и каково сальдо расчётов на конец периода. Для этого можно воспользоваться средствами суммирования ФинГрада:

  1. Выведем окно с запросом параметров отчёта — выберите в главном меню ФинГрада пункт Отчеты, а в нём — пункт Выписка по счёту. Или щёлкните кнопку на панели инструментов ФинГрада.
  2. Щёлкнем мышью в поле Добавить счет... и выберем счёт Деньги под отчёт (чтобы быстрее найти это название в списке, можно ввести с клавиатуры первые символы названия: День...).
  3. Зададим период отчёта, указав начальную и конечную дату или выбрав период.
  4.  Раскроем блок Дополнительно. В строке Суммировать по аналитике выберем аналитику Сотрудник:

  1. Щёлкнем кнопку . ФинГрад выведет отчёт (выписку) на экран:

10.3.4. Раскрытие выписки по аналитике

В выписке по счёту с суммированием по значениям аналитики значения аналитики, по которой производится суммирование (в примере выше — это фамилии и инициалы сотрудников в колонке Сотрудник) подчёркнуты. Это означает, что они представляют собой гиперссылки. Щёлкнув по такой гиперссылке, вы можете вывести раскрытие (расшифровку) строки отчёта, то есть, выписку с проводками, содержащими данное значение аналитики.

При переходе по такой гиперссылке ФинГрад запросит подтверждение:

Если нажать кнопку , ФинГрад выведет раскрытие выписки по данному значению аналитики. То есть выписку, содержащую перечень проводок, сумма которых образует строку в исходном отчёте:

Выбор значений аналитики. Обратите внимание на гиперссылку Выбрать в заголовке сформированного отчёта справа от значений аналитик (ячейки U4 и U7 на рисунке выше. Если перейти по ней, то на экран будет выведено диалоговое окно, в котором можно будет выбрать значения соответствующей аналитики для формирования выписки:

Установите флажки слева от значений аналитики: — включить данное значение аналитики в отчёт, — не включать. Окончив выбор, нажмите кнопку . Вы вернётесь в предыдущее окно с отчётом, но теперь в нём будут показаны проводки с выбранными значениями данной аналитики. На примере выше — отчёт со значениями аналитики Иванов А.А., Петров А.А. и Сидоров И.И.

10.3.5. Пример 4 — выписка с заданными значениями аналитики

ФинГрад позволяет сформировать выписку, содержащую только проводки с заданными значениями аналитики. Сформируем выписку, содержащую сведения о выдаче денег под отчёт сотрудникам Иванову, Петрову и Сидорову:

  1. Выведем окно с запросом параметров отчёта — выберите в главном меню ФинГрада пункт Отчеты, а в нём — пункт Выписка по счёту. Или щёлкните кнопку на панели инструментов ФинГрада.
  2. Щёлкнем мышью в поле Добавить счет... и выберем счёт Деньги под отчёт (чтобы быстрее найти это название в списке, можно ввести с клавиатуры первые символы названия: День...).
  3. Зададим период отчёта, указав начальную и конечную дату или выбрав период.
  4. В блоке Аналитики выписки щёлкнем в поле Добавить аналитику...
  5. В списке аналитик выберем аналитику Сотрудник.
  6. В колонке Ограничения щёлкнем мышью в поле Без ограничений.
  7. В выведенном на экран диалоговом окне выбираем нужные значения аналитики:

Для выбора используем флажки слева от значений аналитики: — включить данное значение аналитики в отчёт, — не включать. Окончив выбор, нажимаем кнопку .

  1. Окно с запросом параметров отчёта будет иметь такой вид:

  1. Нажмём кнопку , и ФинГрад выведет нужный отчёт:

10.3.6. Пример 5 — выписка с заданными корреспонденциями счетов

Иногда требуется создать выписку по операциям с определёнными корреспонденциями счетов. Например, может потребоваться создать выписку не просто об операциях по кассе или по банковскому счёту, но по операциям между кассой и банковским счётом: получение наличных, инкассация выручки и т. п. ФинГрад умеет создавать и такие отчёты. Это делается следующим образом.

  1. Выведем окно с запросом параметров отчёта — выберите в главном меню ФинГрада пункт Отчеты, а в нём — пункт Выписка по счёту. Или щёлкните кнопку на панели инструментов ФинГрада.
  2. Щёлкнем мышью в поле Добавить счет... и выберем нужный счёт или группу счетов.
  3. Зададим период отчёта, указав начальную и конечную дату или выбрав период.
  4.  В блоке Корреспондирующие счета щёлкнем в поле Добавить счет... и выберем нужный счёт из списка.

  1. Нажмём кнопку . ФинГрад выведет отчёт (выписку) на экран:

10.4. Поиск проводок

Ещё одним видом отчётов, содержащим список проводок, является отчёт о поиске проводок.

Чтобы вывести данный отчёт, следует:

  • выбрать в меню ФинГрада пункт Отчёты, а в нём — пункт Поиск проводок…;
  • или щёлкнуть кнопку на панели инструментов ФинГрада.

Окно Поиск проводок. ФинГрад выведет на экран окно с запросом параметров отчёта:

В этом запросе следует ввести свойства тех проводок, которые Вы хотите найти, после чего щёлкнуть мышью кнопку . И ФинГрад выведет список всех проводок, обладающих указанными Вами свойствами.

Если какое-то поле запроса не заполнено, значит, ограничений по данному свойству для искомых проводок Вы задавать не хотите. Если Вы оставите все поля запроса Поиск проводок незаполненными, то ФинГрад выведет список всех проводок в базе данных.

Большинство элементов запроса Поиск проводок объединены в группы. Каждая такая группа выделена в запросе прямоугольной линией. В левом верхнем углу каждой группы выведен заголовок, описывающий назначение этой группы элементов.

Назначение элементов окна Поиск проводок. Расскажем о назначения элементов окна Поиск проводок. Для удобства описания мы пронумеровали на приведённом выше рисунке группы элементов и отдельные элементы этого запроса.

 

Группа/параметр

 

Назначение

 

Счета

 

В списке Счета содержатся счета проводки по которым Вы хотите найти. Для включения счетов в данный список надо щёлкнуть мышью кнопку . Чтобы удалить счёт из этого списка, надо щёлкнуть название этого счёта мышью, и затем щёлкнуть мышью кнопку . Чтобы полностью очистить список счетов, надо щёлкнуть мышью кнопку .

 

Сумма проводки

 

В поле Валюта можно выбратьвалюту искомых проводок, а в полях Сумма от и до — задать ограничения на сумму искомых проводок.

 

Комментарий

 

В поле Комментарий можно задать строку символов, которая должна содержаться в поле Комментарии у искомых проводок. Если включить режим  Полное совпадение, то поле Комментарии у искомых проводок должно в точности совпадать с указанной Вами строкой. А в режиме  Подстрока, поле Комментарии у искомых проводок должно содержать указанную Вами строку.

 

Включить сторн в поиск

 

Если этот режим включён, то ФинГрад будет показывать в результатах поиска сторнированные проводки. Обычно этот параметр выключен.

 

Группировать по аналитикам

 

Если этот режим включён, то ФинГрад будет группировать в отчёте проводки по значениям аналитик, указанным в поле Аналитики (п. 7). Для каждой такой группы будут показаны суммарные обороты, относящиеся к данному значению аналитики

 

Аналитики

 

В список Аналитикивключаются те аналитики, по которым производится группировка(п. 5) или отбор значений (п. 7). Чтобы добавить аналитику в этот список, щёлкните мышью кнопку , чтобы удалить аналитику из списка, щёлкните её в списке мышью, и затем щёлкните мышью кнопку . Чтобы изменить порядок аналитик в списке, используйте кнопки и : кнопка перемещает выделенную в списке аналитику к началу списка, а кнопка к концу списка.

 

Аналитика:

 

Если список Аналитики не пуст, то здесь Вы можете указать значения аналитик, которое должны быть у искомых проводок. Щёлкните в списке Аналитики строчку с названием нужной аналитики, и выберите значения аналитики, которые должны быть в искомых проводках. Чтобы в отчёте присутствовали сведения о проводках, у которых никакое значение данной аналитики не задано, включите режим Включать незаданные. Чтобы выбрать удалённые (неактивные) значения аналитики, включите режим Показывать неактивные.

 

Шаблон вывода проводок

 

Включив режим По фиксированному шаблону, Вы можете указать шаблон документов, по которому будут выводиться найденные проводки

 

Период операции

 

Здесь Вы можете указать диапазон дат для искомых проводок.

 

Период ввода

 

Здесь Вы можете указать диапазон дат, в течение которых искомые проводки были введены в ФинГрад

 

Пользователи

 

В этом списке Вы можете указать, какие пользователи были авторами искомых проводок

 

Цвет

 

Включив режим Цвет, Вы можете указать цвет, которым должны быть оформлены искомые проводки (цвет можно выбрать, щёлкнув мышью кнопку )

Действия после задания параметров поиска. Задав в запросе Поиск проводок свойства тех проводок, которые Вы хотите найти, Вы можете щёлкнуть мышью одну из кнопок в нижней части окна этого запроса:

Кнопка

 

Что сделает ФинГрад…

 

выведет на экран список всех проводок, обладающих указанными Вами свойствами

 

распечатает список всех проводок, обладающих указанными Вами свойствами

 

экспортирует список всех проводок, обладающих указанными Вами свойствами, в табличный редактор Excel

 

позволит сохранить параметры отчёта для повторного использования. Вам будет предложено назначить имя для сохраняемого отчёта.

Кроме того, Вы можете использовать кнопки:

Кнопка

 

Действие ФинГрада

 

Очистит все поля окна Поиск проводок.

 

Закроет окно Поиск проводок, не выполняя поиска проводок. Эту кнопку можно нажать, если Вы передумали и решили не производить поиск проводок.

Замечание. Если Вы вызовете окно с запросом параметров поиска проводок при просмотре найденных проводок (кнопка на панели инструментов), то кнопок , и там не будет. Для вывода отчёта о найденных проводках на принтер, в Excel, и для запоминания параметров отчёта, используйте кнопки на панели инструментов: , и .

Просмотр отчёта о поиске проводок. После того, как Вы задали в запросе Поиск проводок свойства тех проводок, которые Вы хотите найти, и щёлкнули мышью кнопку , ФинГрад сформирует отчёт об искомых проводках и выведет окно с этим отчётом на экран:

Вы можете просматривать выведенный отчёт, перемещаясь по нему с помощью клавиш и , клавиш перемещения курсора, прокручивая колёсико мыши или перетаскивая мышью «бегунок» на линейках прокрутки. Окончив просмотр отчёта, Вы можете закрыть окно отчёта, нажав комбинацию клавиш + или щёлкнув мышью кнопку в правой части строки меню (а если отчёт выведен в отдельном окне документа — то кнопку в правом верхнем углу этого окна).

Более подробно о возможностях при просмотре отчётов рассказано в п. 10.2. Возможности при просмотре отчёта.

10.5. История проводки

В ФинГраде, начиная с версии 4.0, можно вывести отчёт об истории проводки. Этот отчёт показывает, как, кем и когда изменялась проводка, что может быть очень полезно при возникновении вопросов, связанных с проводкой.

Чтобы вывести отчёт об истории проводки:

  1. При просмотре любого отчёта о проводках надо щёлкнуть интересующую проводку правой кнопкой мыши.
  2. В выведенном контекстном меню надо выбрать пункт Показать историю проводки.
  3. ФинГрад сформирует и выведет отчёт об истории проводки.

Этот отчёт показывает:

  1. Все изменения проводки, сделанные вручную.
  2. Автоматические перепроведения проводки (если это зависимая проводка — например, при изменении правил трансформации при импорте).

10.6. Просмотр отчётов с использованием шаблона и без него

В параметрах отчёта о проводках под надписью Шаблон вывода проводок Вы можете либо включить режим По фиксированному шаблону и указать шаблон документов, по которому будут выводиться найденные проводки, либо выключить режим По фиксированному шаблону. Расскажем, в чём особенности этих режимов и чем они отличаются.

10.6.1. Просмотр отчётов с использованием шаблона

Включив в параметрах отчёта о проводках режим По фиксированному шаблону, Вы можете указать шаблон документов, по которому будут выводиться найденные проводки. Шаблон задаёт набор колонок, показываемых в отчёте, их порядок, также он может запретить изменение значений в определённых колонках, и т. п. Подробнее о шаблонах документов рассказано в главе Глава 27. Шаблоны документов.

Если какие-то нужные колонки при использовании шаблона на экране не показаны, надо включить их показ, нажав клавишу или щёлкнув мышью кнопку (Настройка видимости колонок) на панели инструментов отчёта (см. п. 10.2.10. Настройка видимости колонок отчёта).

10.6.2. Просмотр отчётов без шаблона

Если режим По фиксированному шаблону в параметрах отчёта о проводках не задан, то ФинГрад выводит в отчёте все колонки, для которых хотя бы в одной проводке отчёта имеется непустое значение.

Поля в заголовке отчёта. Если в колонке у всех проводок отчёта значения одинаковые, то ФинГрад выносит соответствующее поле в заголовок отчёта. Например, на приведённом ниже рисунке ФинГрад показал в заголовке отчёта 4 поля, значения которых во всех строках отчёта одинаковые.

Преобразование полей заголовка в обычные колонки. Если Вы хотите, чтобы какое-то из полей, вынесенных ФинГрадом в заголовок отчёта, стало обычной колонкой, щёлкните это поле правой кнопкой мыши и выберите в выведенном контекстном меню пункт Открыть колонкуназвание-колонки (например, для поля аналитики Юр. лицо это будет пункт Открыть колонку 'Аналитика Юр. лицо').

Чтобы все поля из заголовка стали обычными колонками, щёлкните любое из них правой кнопкой мыши и выберите в выведенном контекстном меню пункт Открыть все колонки.

Выбор другого значения для поля из заголовка отчёта. Если в заголовке отчёта справа от значения какого-то поля находится гиперссылка Выбрать, то Вы можете, щёлкнув по ней, выбрать другое значение (или другие значения) данного поля. И тогда ФинГрад покажет отчёт о проводках с выбранным значением (выбранными значениями) данного поля.

Замечание. Эта возможность полезна для отчётов, в параметрах которых задано ограничение по значениям аналитик. А именно, если в параметрах отчёта указано, что отчёт должен выводиться для проводок с каким-то определённым значением аналитики, то при просмотре отчёта Вы сможете щелчком по гиперссылке Выбрать справа от названия этой аналитики в заголовке отчёта вывести отчёт по проводкам с другим значением этой аналитики.

10.7. Использование сохранённых отчётов

ФинГрад позволяет создавать отчёты с довольно сложными настройками. Задание всех необходимых настроек для такого отчёта может потребовать немало времени. Поэтому ФинГрад позволяет сохранять настройки отчётов, и формировать отчёты со сделанными настройками. В этом параграфе мы расскажем о сохранении параметров отчётов и их использовании.

10.7.1. Список сохранённых отчётов

ФинГрад хранит в своей базе данных список сохранённых отчётов (точнее, настроек отчётов). Этот список можно вывести на экран, щёлкнув кнопку на панели инструментов ФинГрада или выбрав команду меню Отчёты | Сохранённые отчёты:

Как видно, список сохранённых отчётов состоит из групп отчётов. На приведённом выше рисунке в списке содержатся 8 групп: Баланс, Банк, Касса, Отчет о движении денежных средств, Отчет о прибылях и убытках, Прочие, Реализация и Себестоимость. Слева от названия каждой группы отчётов в списке выведен значок или . Щелчок мышью по значку раскрывает перечень отчётов в группе, а щелчок по значку , наоборот, сворачивает (прячет) перечень отчётов группы.

Первоначально в списке отчётов имеется только одна группа отчётов Прочие. Вы можете создавать в этом списке столько групп отчётов, сколько необходимо, и назвать их как Вам угодно. В каждой группе отчётов может быть сколько угодно отчётов.

Целесообразно создавать содержательные, тематические группы отчётов. Например, Касса — отчёты по кассе или кассам, Банк — отчёты по банковским счетам, и т. д.

10.7.2. Использование списка сохранённых отчётов

Используя список сохранённых отчётов (напомним, что на самом деле это список настроек отчётов), Вы можете:

  • сформировать отчёт с такими же в точности параметрами, которые были запомнены при сохранении отчёта;
  • сформировать отчёт на основе отчёта из списка сохранённых отчётов. То есть, для любого элемента списка сохранённых отчётов Вы можете вывести параметры этого отчёта на экран, затем исправить эти параметры и сформировать отчёт с исправленными параметрами.

Чтобы сформировать отчёт, используя список сохранённых отчётов, следует:

  1. Вывести на экран список Сохранённые отчёты, щёлкнув кнопку на панели инструментов ФинГрада или выбрав команду меню Отчёты | Сохранённые отчёты.
  2. Выделить в этом списке строку с названием нужного отчёта, щёлкнув её мышью. Для этого сначала может потребоваться, щёлкнув мышью по значку , раскрыть перечень отчётов в той группе, в которую входит нужный отчёт.

Можно также ввести с клавиатуры строку символов из названия нужного отчёта. Тогда ФинГрад выведет в списке Сохранённые отчёты перечень отчётов, у которых в названиях имеется введённая Вами строка символов.

  1. Щёлкнуть мышью одну из следующих кнопок:

Кнопка

 

Действие

 

ФинГрад сформирует отчёт с такими же в точности параметрами, которые были запомнены при сохранении отчёта

 

ФинГрад выведет на экран диалоговый запрос с параметрами сохранённого отчёта. Вы сможете исправить эти параметры и сформировать отчёт с исправленными параметрами

 

ФинГрад закроет окно Сохранённые отчёты, не создавая отчёта. Эту кнопку можно нажать, если Вы передумали и решили не создавать отчёт.

10.7.3. Сохранение параметров отчёта

Чтобы запомнить параметры просматриваемого отчёта, надо щёлкнуть мышью кнопку на панели инструментов. ФинГрад выведет запрос, в котором предложит задать имя для сохраняемых параметров отчёта:

В этом запросе следует:

  1. В поле Имя отчёта ввести имя, содержательно описывающее формируемый при данных параметрах отчёт.
  2. В поле Группа отчетов ввести наименование группы, в которую будет помещён отчёт, или выбрать наименование этой группы из списка, щёлкнув значок в правой части этого поля.
  3. Щёлкнуть мышью кнопку .

Замечание. Кнопка может выводиться и в окне с запросом параметров отчёта. Щёлкнув её мышью, Вы точно так же можете сохранить параметры отчёта.

Если отчёт с таким именем уже имеется в списке. Если отчёт с указанным Вами именем уже существует в списке сохранённых отчётов, ФинГрад выведет запрос о том, что Вы хотите — заменить существующий отчёт в списке сохранённых отчётов, или же создать новый отчёт:

Вы можете:

  • щёлкнуть мышью кнопку , чтобы заменить параметры у ранее сохранённого отчёта;
  • или щёлкнуть мышью кнопку , если Вы хотите сохранить параметры отчёта в качестве нового элемента списка сохранённых отчётов. В этом случае ФинГрад снова выведет на экран запрос, в котором Вы надо будет указать имя отчёта и название группы отчётов.